Post New Topic  Post A Reply
my profile | register | search | faq | forum home
  next oldest topic   next newest topic
» MacOSX -   » Compile Problems   » ffmpeg

UBBFriend: Email this page to someone!    
Author Topic: ffmpeg

posted September 15, 2002 06:15 PM           Edit/Delete Post  Reply With Quote 
Well, here's the situation. I wanted to compile and install ffmpeg. So, I grabbed the tarball, and saq this when I did ./configure :

Install prefix /usr/local
Source path /Volumes/Scratch/ffmpeg
C compiler cc
make make
CPU powerpc
Big Endian yes
MMX enabled no
AltiVec enabled yes
gprof enabled no
zlib enabled yes
mp3lame enabled no
vorbis enabled no
a52 support yes
a52 dlopened no
Creating config.mak and config.h

I figured that I would like to work with lame and vorbis, so I went to the various project pages, then compiled and installed what I could find (lame 3.92, libao 0.8.3, libogg 1.0, libvorbis 1.0, and vorbis tools 1.0). I erased the config.mak and config.h, and tried ./configure again, same result. A few days and a couple restarts later, and still the same result. Does anyone know how to engage mp3 and ogg support in ffmpeg? I thought that installing the libraries and software that I did would be sufficient.

I haven't tried taking it past ./configure, since I don't want to waste my time with an install I will have to reinstall.


Also of possible note is that ogg123 didn't compile, even though oggenc, oggdec, and ogginfo came out fine.

IP: Logged

All times are Pacific Time  

Post New Topic  Post A Reply Close Topic    Move Topic    Delete Topic next oldest topic   next newest topic
Hop To:

Contact Us |

Powered by Infopop Corporation
Ultimate Bulletin BoardTM