Post New Topic  Post A Reply
my profile | register | search | faq | forum home
  next oldest topic   next newest topic
» MacOSX - forked.net   » Ported Packages   » BitchX not working for me!

UBBFriend: Email this page to someone!    
Author Topic: BitchX not working for me!
Miguel
Junior Member
Member # 203

posted October 31, 2001 07:52 AM      Profile for Miguel   Email Miguel   Send New Private Message      Edit/Delete Post  Reply With Quote 
I downloaded and installed BitchX 1.0c18 from this site and it's not working. Here's what it says after I run it:

Process [pid]
Using terminal type [xterm|vt100]
setup term failed: 0

So we'll be running in dumb mode...

And it exits.

As you can see, i've tried it from an xterm and from the OS X.1 terminal (vt100). Any help would be appreciated.

Thanks,

Miguel


Posts: 1 | From: US | Registered: Oct 2001  |  IP: Logged
willy wonka
Member
Member # 32

posted November 01, 2001 04:18 PM      Profile for willy wonka   Author's Homepage        Edit/Delete Post  Reply With Quote 
you're doing better than me. i get a screen filled with things like this:
$<5>$<3>$<2>$<2>$<2>$<2>$<2>$<2>$<3>
$<5>$<3> $<2> $<2>$<2>$<2>$<2>$<5>$<3> $<2>?$<2>$<2>$<2>$<2> $$<5>$<3> $<2>ܰ??$<2>$<2>$<2>$<2> $<2>$<2>$<2>
and then it exits with a bus error. granted, i can't remember if i download the binary from here or if that was one of my failed attempts to compile and install myself.

--------------------

--

-willy
"Freedom will henceforth be compulsory." -Random Party Manifesto


Posts: 92 | Registered: Aug 2001  |  IP: Logged
apex
Administrator
Member # 1

posted November 22, 2001 11:28 PM      Profile for apex   Email apex   Send New Private Message      Edit/Delete Post  Reply With Quote 
Install ncurses http://macosx.forked.net/ports/ncurses-5.2.pkg.tgz .
Posts: 307 | From: Alaska | Registered: Aug 2001  |  IP: Logged
willy wonka
Member
Member # 32

posted November 26, 2001 06:27 AM      Profile for willy wonka   Author's Homepage        Edit/Delete Post  Reply With Quote 
bleh. problem was, i was trying to run my own compiled version of bitchx. downloaded and installed the package, and it works.

--------------------

--

-willy
"Freedom will henceforth be compulsory." -Random Party Manifesto


Posts: 92 | Registered: Aug 2001  |  IP: Logged
A_D
Junior Member
Member # 231

posted November 26, 2001 08:52 AM      Profile for A_D     Send New Private Message      Edit/Delete Post  Reply With Quote 
yeah just download bitchx and ncurses from here and it will work
Posts: 13 | Registered: Nov 2001  |  IP: Logged
forty_two
Junior Member
Member # 253

posted December 09, 2001 09:27 PM      Profile for forty_two     Send New Private Message      Edit/Delete Post  Reply With Quote 
BitchX seems to be working fine for me (precompiled package downloaded from this site) but for signoffs and joins, the following is displayed:

??1;31m? SignOff user: #channel (message)

Is that junk on the left supposed to be the time? Does anyone else have this problem?


Posts: 7 | Registered: Dec 2001  |  IP: Logged
willy wonka
Member
Member # 32

posted December 10, 2001 05:50 AM      Profile for willy wonka   Author's Homepage        Edit/Delete Post  Reply With Quote 
mine did that after i updated to 10.1.
to fix: go to your terminal preferences, shell, and change your text encoding. mine's ascii. works a bit better.

--------------------

--

-willy
"Freedom will henceforth be compulsory." -Random Party Manifesto


Posts: 92 | Registered: Aug 2001  |  IP: Logged
antosha
Junior Member
Member # 423

posted May 14, 2002 02:08 PM      Profile for antosha     Send New Private Message      Edit/Delete Post  Reply With Quote 
Hey, I've just downloaded BitchX-1.0c19-MacOS-X, and get the following error when I type ./BitchX

dyld: ./BitchX can't open library: /usr/local/lib/libncurses.dylib.5 (No such file or directory, errno = 2)

any ideas

Anton

---Edit---
I'm downloading http://home.pacifier.com/~jdaniel/ncurses-5.2.pkg.tgz I'll report if it works

[ May 14, 2002: Message edited by: antosha ]

---Edit 2---
Hey, I installed ncurses, but my fonts are still all scrambled with $<2> like willies' were. any suggestions? Changing fonts to ASCII doesn't get rid of them...

[ May 14, 2002: Message edited by: antosha ]
--Edit 3---
Hey, I downloaded GL Term from http://www.pollet.net/GLterm/GLterm.dmg.gz and everything works well with ANSI fonts. thanks

[ May 14, 2002: Message edited by: antosha ]


Posts: 1 | From: Moscow, Russia | Registered: May 2002  |  IP: Logged
p0w3r
Junior Member
Member # 508

posted September 13, 2002 12:11 AM      Profile for p0w3r     Send New Private Message      Edit/Delete Post  Reply With Quote 
hmm, i get the error message;

BitchX - Based on EPIC Software Labs epic ircII (1998).
Version (BitchX-1.0c17) -- Date (19990221).
Process [584]
Using terminal type [vt100]

Your terminal (vt100) cannot run IRC II in full screen mode.
The following features are missing from your TERM setting.
Cursor movement
Clear screen
Clear to end-of-line
Cursor right
Cursor left
Scrolling
So we'll be running in dumb mode...

but it doesn't start up!!#$


Posts: 3 | From: Australia | Registered: Sep 2002  |  IP: Logged
p0w3r
Junior Member
Member # 508

posted September 13, 2002 12:34 AM      Profile for p0w3r     Send New Private Message      Edit/Delete Post  Reply With Quote 
BitchX - Based on EPIC Software Labs epic ircII (1998).
Version (BitchX-1.0c17) -- Date (19990221).
Process [665]
Using terminal type [vt100]

Your terminal (vt100) cannot run IRC II in full screen mode.
The following features are missing from your TERM setting.
Cursor movement
Clear screen
Clear to end-of-line
Cursor right
Cursor left
Scrolling
So we'll be running in dumb mode...
\

how do i fix my terminal


Posts: 3 | From: Australia | Registered: Sep 2002  |  IP: Logged
apex
Administrator
Member # 1

posted September 14, 2002 10:31 AM      Profile for apex   Email apex   Send New Private Message      Edit/Delete Post  Reply With Quote 
Read the above posts and install ncurses.
Posts: 307 | From: Alaska | Registered: Aug 2001  |  IP: Logged
p0w3r
Junior Member
Member # 508

posted September 15, 2002 04:33 PM      Profile for p0w3r     Send New Private Message      Edit/Delete Post  Reply With Quote 
ncurses are installed!

i ncurses 5.2-8 Full-screen ascii drawing library

maybe BitchX isn't seeing it?


Posts: 3 | From: Australia | Registered: Sep 2002  |  IP: Logged
frasilva
Junior Member
Member # 723

posted February 07, 2004 11:59 AM      Profile for frasilva     Send New Private Message      Edit/Delete Post  Reply With Quote 
i get this (ncurse installed)


dyld: BitchX Undefined symbols:
BitchX undefined reference to _BC expected to be defined in /usr/lib/libSystem.B.dylib
BitchX undefined reference to _UP expected to be defined in /usr/lib/libSystem.B.dylib
Trace/BPT trap


Posts: 1 | Registered: Feb 2004  |  IP: Logged

All times are Pacific Time  

Post New Topic  Post A Reply Close Topic    Move Topic    Delete Topic next oldest topic   next newest topic
Hop To:

Contact Us | macosx.forked.net

Powered by Infopop Corporation
Ultimate Bulletin BoardTM 6.1.0.2