Post New Topic  Post A Reply
my profile | register | search | faq | forum home
  next oldest topic   next newest topic
» MacOSX -   » General Discussion   » VIM Question

UBBFriend: Email this page to someone!    
Author Topic: VIM Question
Junior Member
Member # 352

posted March 03, 2002 08:01 AM      Profile for Cracked   Email Cracked   Send New Private Message      Edit/Delete Post  Reply With Quote 
I use mandrake 8.1 at work and OSX at the house. I love my OSX, but the vi editor on my linux box is easier to use. i.e. when I page up or page down, it moves my cursor up a page or down a page rather than just displaying the page above or below.

Also, I do not have the 'mode' (ie "insert") display when I use vi on OSX. I thought maybe it was a shell thing, so I installed bash, then I thought maybe it is a vi thing, so I tried installing vim 6.0 from It acted like it installed successfully, but when I tried to run vim I received the following error:

vim can't open library: /usr/X11R6/lib/libXext.6.dylib (No such file or directory, errno = 2)

If anyone has any ideas, I would love to hear them. Thanks!

Posts: 1 | Registered: Mar 2002  |  IP: Logged
willy wonka
Member # 32

posted March 06, 2002 05:14 AM      Profile for willy wonka   Author's Homepage        Edit/Delete Post  Reply With Quote 
looks like what you're running is trying to use Xwindows.
few things i'd try:
first, make sure your ncurses is up to date:
if you want, try to install Xwindows.
i'd say try the vim from here, but it's giving me similar errors:
% vim
dyld: vim can't open library: /usr/X11R6/lib/libXaw.7.dylib (No such file or directory, errno = 2)



"Freedom will henceforth be compulsory." -Random Party Manifesto

Posts: 92 | Registered: Aug 2001  |  IP: Logged

All times are Pacific Time  

Post New Topic  Post A Reply Close Topic    Move Topic    Delete Topic next oldest topic   next newest topic
Hop To:

Contact Us |

Powered by Infopop Corporation
Ultimate Bulletin BoardTM